So much time has passed since the last update, but I’ve finally found the time to work on this lovely package :D
But before I get into details, I should first warn you:
This update contains breaking changes!
I refactored basically all files. For most of them it was just code formatting and minor adjustment, like explicit visibility modifiers and naming of private or local variables.
But I’ve also changed the naming scheme to classic C# naming (CamelCase) and I also renamed the two Manager classes.
So you may be thinking something like this:
You did what?! Why the hell would you do such things?
Well, let’s first talk about the manager classes. Up to now there were two classes called Manager
, one inside the API
namespace and one in the UI
namespace. This was of course semantically correct, but of course it was also a bit inconvenient and also a bit confusing for newbies. One nasty problem was that you had to use the fully qualified name whenever you wanted to use both Manager classes from within the same class, so you had to write GameJolt.API.Manager
and GameJolt.UI.Manager
. Furthermore Manager
is a really ambiguous term which might probably already be used by some user defined classes. Therefore I’ve decided to rename them and I changed their names to GameJoltAPI
and GameJoltUI
.
Yes…I know now the fully qualified name looks very ugly and redundant (GameJolt.API.GameJoltAPI
), but due to a lack of a better name, I guess this name is good enough :D, at least now it is obvious what these classes are used to.
The other big change is the naming scheme. Up to now the package was mostly using the Unity naming scheme, which uses UpperCamelCase for methods, but lowerCamelCase for fields. This is of course not the naming scheme recommended by Microsoft. Since I’m a C# developer and because I would like this package to be just a “normal” C# library, I’ve decided to use the recommended C# naming convention.
So I hope you see it just like me and prefer a clear and consistent naming convention :D
Change Log
Add
Added LogHelper class and LogLevel setting. All log messages with a level below the provided one are discarded. (see issue #2)
Changed
Renamed Manager classes to
GameJoltAPI
andGameJoltUI
(see issue #21):warning: This is a breaking change! If you’re migrating from an older version, please have a look at the migration page.
“Mega Refactoring” - refactored nearly all files (see issue #20)
applied consistent style (code formatting)
corrected namespaces
fixed naming scheme (now consistently using C# CamelCase)
used explicit visibility modifiers
adjusted visibility
:warning: This is possibly a breaking change, because it changes the naming scheme
Fixed
3 comments